SwiftUIの基本を身につけたい方はこちら

【CocoaPods】Ignoring ffi-1.15.5 because its extensions are not built. Try: gem pristine ffi –version 1.15.5

エラー内容

pod installやpod initをしたら以下のようなエラーが表示されました。

Ignoring ffi-1.15.5 because its extensions are not built. Try: gem pristine ffi –version 1.15.5
Ignoring racc-1.6.0 because its extensions are not built. Try: gem pristine racc –version 1.6.0
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/lib/cocoapods/user_interface/error_report.rb:34:in `force_encoding’: can’t modify frozen String (FrozenError)
from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/lib/cocoapods/user_interface/error_report.rb:34:in `report’
from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/lib/cocoapods/command.rb:66:in `report_error’
from /Library/Ruby/Gems/2.6.0/gems/claide-1.1.0/lib/claide/command.rb:396:in `handle_exception’
from /Library/Ruby/Gems/2.6.0/gems/claide-1.1.0/lib/claide/command.rb:337:in `rescue in run’
from /Library/Ruby/Gems/2.6.0/gems/claide-1.1.0/lib/claide/command.rb:324:in `run’
from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/lib/cocoapods/command.rb:52:in `run’
from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/bin/pod:55:in `<top (required)>’
from /usr/local/bin/pod:23:in `load’
from /usr/local/bin/pod:23:in `<main>’
/Library/Ruby/Gems/2.6.0/gems/xcodeproj-1.21.0/lib/xcodeproj/project.rb:228:in `initialize_from_file’: [Xcodeproj] Unknown object version (56). (RuntimeError)
from /Library/Ruby/Gems/2.6.0/gems/xcodeproj-1.21.0/lib/xcodeproj/project.rb:113:in `open’
from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/lib/cocoapods/command/init.rb:41:in `validate!’
from /Library/Ruby/Gems/2.6.0/gems/claide-1.1.0/lib/claide/command.rb:333:in `run’
from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/lib/cocoapods/command.rb:52:in `run’
from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/bin/pod:55:in `<top (required)>’
from /usr/local/bin/pod:23:in `load’
from /usr/local/bin/pod:23:in `<main>’

原因

このエラーは、ffi-1.15.5racc-1.6.0というライブラリが見つからないため発生しています。

解決方法

そのライブラリが見つからないので、エラーになっているので、そのライブラリをインストールすれば解決できます。バージョンは合わせてください。

sudo gem install ffi -v '1.15.5'

ただ、この方法でracc-1.6.0の方をインストールしてもうまくいきませんでした。。色々な方法を行ってもうまくいかず。。

なので、最終手段です。

gemで扱ってるのはcocoapodsしかないので、gemでインストールしてるものを全てアンインストールしてcocoapodsをもう一度インストールします。

まず、以下のコマンドを打って全てアンインストールします。ynを聞かれるので、全てyにしました。

sudo gem uninstall --all

そしたら、もう一度cocoapodsをインストールします。

sudo gem install cocoapods

これで、podが再度使えるようになりました。