【CocoaPods】pod installでエラー:Analyzing dependencies

エラー内容

pod installでライブラリをインストールしようとしたら、以下のようなエラーが表示された。

Analyzing dependencies
/Library/Ruby/Gems/2.6.0/gems/ethon-0.15.0/lib/ethon/curls/classes.rb:36: [BUG] Illegal instruction at 0x00000001011ec000
ruby 2.6.8p205 (2021-07-07 revision 67951) universal.arm64e-darwin21
~~~~~~

解決方法

podを再セットアップする。

まず、podのリポジトリを削除する(CocoaPodsのバージョンによっては、trunkのところをmasterに書き換える必要がある。)

pod repo remove trunk

再度セットアップする

pod setup

そしてpod install

pod install